当前位置:首页 > 问答

指标背离选股

我来帮TA回答

谁能帮我编个macd底背离的选股公式,不盛感激!

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2,COLORSTICK;
DIFF:=SUM(MA1-MA2,0);
SUMMACD:=SUM(MACD,0);
W1:=BARSLAST(CROSS(MA2,MA1))+1;
W2:=BARSLAST(CROSS(MA1,MA2))+1;
W3:=BARSLAST(CROSS(MACD,0))+1;
W4:=BARSLAST(CROSS(-MACD,0))+1;

趋势力度:IF(K,SUMMACD-REF(SUMMACD,MIN(W3,W4)),DIFF-REF(DIFF,MIN(W1,W2)));
趋势平均力度:趋势力度/IF(K,(MIN(W3,W4)+1)/20,(MIN(W1,W2)+1)/20),COLORSTICK;
MAX趋势平均力度:HHV(趋势平均力度,34);
MIN趋势平均力度:LLV(趋势平均力度,34);
--------------------------------------------------------------------------------------------------------------------------------------------
K值可调,调成“0”是通过均线缠绕面积判断背驰
调成“1”是通过macd面积判断背驰。
白线为均线(或macd )到目前为止的面积,白线的拐点(即某一段的最大值(绝对值))是均线或macd面积。如果K调成1,红绿柱为凭据趋势力度。

此指标不是选股指标,是个副图指标,因为选股指标需要判断前后面积的大小,难度极大,不易做出,目前还没发现有人能写出来。

求通达信5分钟和15分钟周期MACD同时背离的选股公式

N:=60;
DD:=C=LLV(C,N);{60日最低点}
DDSJ:=BARSLAST(REF(DD,1));{上一低点时间}
DDGJ:=REF(CLOSE,DDSJ+1)>CLOSE;{股价趋势}
GD:=C=HHV(C,N);{60日最高点}
GDSJ:=BARSLAST(REF(GD,1));{上一高点时间}
GDGJ:=REF(CLOSE,GDSJ+1)<CLOSE;{股价趋势}
MACD:="MACD.MACD";
MDZB:=REF(MACD,DDSJ+1)<MACD;{MACD指标趋势}
底背离:DDGJ AND MDZB;

设立周期为5分和15分全部条件相与。N可选。
今天选出2只。002281 300246

请问怎么用选股器选macd底背离的股票? 条件怎么设置?

这个要选应该技术很难吧,各种背离情况都不一样,一般都是自己观察和分析的。

请那位大师帮忙改写一个MACD背离的选股公式,顶背离选出 ,底背离也可以选出,谢谢!

名:《说聊斋》演唱:彭作曲:王立平

请高手把通达信“买入必涨”主图指标公式改成选股公式,谢谢!

B1:=EMA((2*CLOSE+HIGH+LOW)/4,5);
趋势:=MA(C,90),COLORRED;
MA14:=MA(CLOSE,14);
码:=COST(50),COLORYELLOW;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
XG:CROSS(DIFF,DEA);
编写公式,修改公式。盘中预警,条件选股。公式解密,去除或增加时间限制。
点我的用户名,再点私信。

某天最低价跌幅大于6个点以上的公式源码 通达信的

某天最低价跌幅大于6个点,和谁比跌幅大于六个点啊
和昨天收盘价比还是和昨天最低价比还是和今天开盘价比
和昨天昨天收盘价比
xg:(l-ref(c,1))/ref(c,1)<-0.06;
和昨天最低价比
xg:(l-ref(l,1))/ref(l,1)<-0.06;
和今天开盘价比
xg:(l-o)/o<-0.06;
  • 财惠网
  • 炒股配资网
  • 巨财网
  • 黄金喊单
  • 原油直播室
  • 原油期货网
  • 原油期货
  • 期货直播间
  • 黄金喊单
  • 外盘期货喊单
  • 期货直播室
  • 恒指喊单直播室
  • 期货直播室
  • 薛城财经
  • 国际期货喊单
  • 助腾财经
  • 黄金喊单
  • 中银网
  • 恒指期货直播
  • 美原油直播室
  • 黄金喊单
  • 金融知识科普网
  • 亿森财经
  • >凯贝股票网
  • 财姐网
  • >东台网
  • 广东炒股网